注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

一粒浮尘

飘渺虚无

 
 
 

日志

 
 

ubuntu14.04下启动skype出现:skype: error while loading shared libraries: libGL.so.1: wrong ELF class: ELFCLASS64  

2015-04-27 10:06:32|  分类: Linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
错误是因为库的位不对。skype需要的是32bit的libGL.so.1,只需通过如下命令建立一个32bit的库的符号链接即可:
sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib/

更新:
今天打开wzinote时发现出了问题,遇到与打开skype时一样的问题,不同的是wzinote需要的是64位的库,而我昨天为了skype正常登录,做了一个32位的libGL.so.1的链接放在/usr/lib下面。。。
今天和台式机的配置对比了一下,发现完美的解决方案是将/etc/ld.so.conf.d/下的x86_64-linux-gnu_GL.conf所指向的/etc/alternatives/x86_64-linux-gnu_gl_conf里的内容做一些修改,修改后如下
/usr/lib/nvidia-304
/usr/lib32/nvidia-304
保存之后sudo ldconfig,接着一切就OK啦!
  评论这张
 
阅读(704)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017